Paraglider BartPE Plugins

Webroot Spy Sweeper 3.5 Plugin

This is a PEBuilder plugin for the WebRoot SpySweeper 3.5 program.

Create a folder named SpySweeper in your pebuilder plugin directory.

Extract the contents of the cab file into the SpySweeper directory ( maintaining the folder structure in the plugin ).

You should finish up with the following files:

SpySweeper.htm
SpySweeper.inf
SpySweeper.xml
Files\SpySweeper.cmd
 

Download the SpySweeper program from Webroot and install to your hard drive. Copy all files ( including sub-directories) from the "WebRoot\Spy Sweeper" directory to your SpySweeper\Files directory. Delete any files in the Files\Quarantine and Files\Temp directories. Delete Masters.Bak from the Files\Masters directory if it exists.

You should finish up with at least these extra files / directories:

Files\Bt01.exe
Files\file_id.diz
Files\image01.gif
Files\image02.gif
Files\image03.gif
Files\image04.gif
Files\image05.gif
Files\install.dat
Files\Language.dll
Files\license.txt
Files\Masters
Files\NDN01.exe
Files\NewNews.txt
Files\readme.txt
Files\report.ini
Files\sis.dll
Files\SpyHelp.chm
Files\SpyNews.htm
Files\SpySweeper.exe
Files\SR3List.dll
Files\SSCtxMnu.dll
Files\TP.exe

Files\Masters\hostsfile.hst
Files\Masters\masters.mst

The following are empty directories only:

Files\Quarantine
Files\Temp

If you are not using an English version of PE or if you have renamed your profile directories to something other than their default names then you will need to edit the spysweeper.cmd file and change the following line:

if not exist "%ramdrv%\documents and settings\default user\Application Data\WebRoot\*" xcopy "%SystemDrive%\documents and settings\default user\Application Data" "%ramdrv%\documents and settings\default user\Application Data\" /E

Change the destination of the xcopy to the directory names you are using.

Before any attempt is made to run SpySweeper with RunScanner make sure it runs without any problems when run directly without being under control of RunScanner.

If you find that running SpySweeper without RunScanner works but when run with RunScanner you get an error saying it could not create directories names \WebRoot\..... then try increasing the /t parameter in SpySweeper.cmd. By default its /t 1000. Try changing this to /t 10000.